用户名: 密码: 忘记密码? 注册
收藏此问题 发表新评论

龙芯3号终于有点正式消息啦

昨天,帮同学安装了64位的ubuntu,发现安装i386的deb包时显示架构不支持,无法安装.当时感到很奇怪,我今年暑假安了一次suse64位,完全可以安装32位包,当时suse源上的firefox,openoffice都是i586包.查看了论坛找到如下方法:
首先安张32位库
sudo apt-get install ia32-libs*
sudo apt-get install getlibs #如果没有,到这个地址下http://frozenfox.freehostia.com/cappy/
然后就可以安装32位包
安装时加--force-architecture
然后用getlibs安装依赖库
,如
sudo dpkg -i --force-architecture cairo-dock*.deb
sudo getlibs cairo-dock


终于又可以用32位的软件了. :wink:
mplayer 安装w64看下贴:
http://forum.ubuntu.org.cn/viewtopic.php?t=94488


反安装用 sudo dpkg -P 软件名

sudo dpkg -P cairo-dock

最后由 syrano 编辑于 2008-05-11 9:11,总共编辑了 6 次
昵称: syrano  时间: 2007-12-21 21:02:00
昨天刚换成64位的
学习中
谢谢了
昵称: lanif08  时间: 2008-01-01 16:18:00
楼主帮大忙啦QQQ
有了64位的处理器安装32位的操作系统是在浪费计算资源啊。
昵称: dr_liu  时间: 2008-01-08 12:46:00
用新立得的怎么办?
昵称: titainium  时间: 2008-01-09 18:09:00
titainium 写道:
用新立得的怎么办?

源里的好像都有64位的吧,

最后由 syrano 编辑于 2008-01-10 18:27,总共编辑了 1 次
昵称: syrano  时间: 2008-01-09 18:15:00
我的amd的64位处理器安装的red hat 32位就是i686的包,用起来感觉一般才换成这个ubuntu的,应该比那个要好吧
昵称: itux  时间: 2008-01-10 14:31:00
不是说
引用:
sudo apt-get install ia32-libs*
然后就可以安装32位包
安装时加--force-architecture
,如
sudo dpkg --force-architecture -i opera_9.25-20071214.6-shared-qt_en_i386.deb

这样吗?
我要是通过新立得安装32位软件怎么玩?可以选上--force-architecture吗?
昵称: titainium  时间: 2008-01-10 17:56:00
经典啊 :!:
昵称: szjuntao  时间: 2008-02-01 19:48:00
成功运行Opera9.50,谢谢楼主
昵称: flying.space  时间: 2008-02-05 19:14:00
flying.space 写道:
成功运行Opera9.50,谢谢楼主
我运行OPERA提示找不到libqt-mt.so.3后来我安装了EVA有了这个kde的库成功运行OPERA9.50B。同样QQQ楼主
昵称: dr_liu  时间: 2008-02-07 01:55:00
dr_liu 写道:
flying.space 写道:
成功运行Opera9.50,谢谢楼主
我运行OPERA提示找不到libqt-mt.so.3后来我安装了EVA有了这个kde的库成功运行OPERA9.50B。同样QQQ楼主

\
Opera9.50已有64的了
昵称: seanfj  时间: 2008-02-23 03:57:00
太感谢楼主了 ,这个很实用阿!
昵称: zchse  时间: 2008-03-14 22:56:00
我用了楼主说的办法
怎么显示这种情况?


123@123-laptop:/media/disk-2$ sudo dpkg --force-architecture -i opera_9.50b-20071024.6-shared-qt_en_i386.deb
dpkg - 警告,由于您打开了 --force 选项,我忽略了一些问题的存在:
软件包的体系架构(i386)与本机系统的架构(amd64)不符
选中了曾被取消选择的软件包 opera。
(正在读取数据库 ... 系统当前总共安装有 102620 个文件和目录。)
正在解压缩 opera (从 opera_9.50b-20071024.6-shared-qt_en_i386.deb) ...
正在设置 opera (9.50-20071024.6) ...

123@123-laptop:/media/disk-2$ opera
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
/usr/lib/opera/9.50-20071024.6/opera: error while loading shared libraries: libqt-mt.so.3: wrong ELF class: ELFCLASS64
昵称: Mutial  时间: 2008-04-21 16:54:00
Mutial 写道:
我用了楼主说的办法
怎么显示这种情况?


123@123-laptop:/media/disk-2$ sudo dpkg --force-architecture -i opera_9.50b-20071024.6-shared-qt_en_i386.deb
dpkg - 警告,由于您打开了 --force 选项,我忽略了一些问题的存在:
软件包的体系架构(i386)与本机系统的架构(amd64)不符
选中了曾被取消选择的软件包 opera。
(正在读取数据库 ... 系统当前总共安装有 102620 个文件和目录。)
正在解压缩 opera (从 opera_9.50b-20071024.6-shared-qt_en_i386.deb) ...
正在设置 opera (9.50-20071024.6) ...

123@123-laptop:/media/disk-2$ opera
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.
/usr/lib/opera/9.50-20071024.6/opera: error while loading shared libraries: libqt-mt.so.3: wrong ELF class: ELFCLASS64

opera依赖libqt3-mt
sudo apt-get install libqt3-mt
不过opera已经有64位的了,可以直接安装64位的opera
昵称: syrano  时间: 2008-04-21 17:03:00
谢谢,试试星际译王现。
昵称: SecretZero  时间: 2008-04-22 05:51:00
汗~用这个方法安装星际译王不能启动。。~
昵称: SecretZero  时间: 2008-04-22 05:59:00
SecretZero 写道:
谢谢,试试星际译王现。

星际译王有64位的。
昵称: syrano  时间: 2008-04-22 08:51:00
哪里?我找不到啊!

请帮帮给个地址。谢谢。
昵称: SecretZero  时间: 2008-04-26 00:31:00
SecretZero 写道:
哪里?我找不到啊!

请帮帮给个地址。谢谢。

sudo aptitude install stardict
昵称: syrano  时间: 2008-04-26 10:11:00
楼主此法甚好不赖,能装32位的了
但是,不知道各位装上后能用不?
我装上后,有的点击打不开的阿?半年没反应、、、、
要不这样:我转附上32位飞信链接,64的试试看能用不?
http://www.libfetion.cn/Linux_demoapp_download.html
昵称: ubuntuing  时间: 2008-04-27 17:43:00
我的也是 用的是8.04版本的系统 安装OPERA 能安装 却无法使用
希望楼主能解答下这个问题
昵称: fCys  时间: 2008-04-29 12:08:00
fCys 写道:
我的也是 用的是8.04版本的系统 安装OPERA 能安装 却无法使用
希望楼主能解答下这个问题

opera已经有64位的了。
昵称: syrano  时间: 2008-04-29 12:41:00
作个记号,对楼主表示支持
昵称: cokerwu  时间: 2008-05-04 02:20:00
我下了个32位的飞信,按照楼主的方法安装
出现了不符合 但能安装 安装好后点击却不能启动
怎么能解决
昵称: huadiw  时间: 2008-05-04 12:10:00
有冲突
sudo apt-get install ia32-libs*

The following information may help to resolve the situation:

The following packages have unmet dependencies:
ia32-libs: Conflicts: ia32-libs-gtk
Conflicts: ia32-libs-openoffice.org but 17 is to be installed
Conflicts: ia32-libs-sdl
E: Broken packages
昵称: flyincat  时间: 2008-05-08 15:20:00
这个要顶
昵称: bailangvii  时间: 2008-05-09 13:00:00
getlibs 打开链接那么多
我应该下哪个呢 下来后要怎么样安装呢
我是个菜鸟希望能指点下
昵称: salira  时间: 2008-05-18 12:15:00
salira 写道:
getlibs 打开链接那么多
我应该下哪个呢 下来后要怎么样安装呢
我是个菜鸟希望能指点下

http://www.boundlesssupremacy.com/Cappy ... 05-all.deb
昵称: syrano  时间: 2008-05-18 15:18:00
这是为何:

sudo apt-get install ia32-libs*
[sudo] password for chineseli:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting ia32-libs for regex 'ia32-libs*'
Note, selecting ia32-libs-dev for regex 'ia32-libs*'
Note, selecting ia32-libs-gtk for regex 'ia32-libs*'
Note, selecting ia32-libs-sdl for regex 'ia32-libs*'
Note, selecting ia32-libs-openoffice.org for regex 'ia32-libs*'
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
昵称: chineseli  时间: 2008-07-21 13:46:00
chineseli 写道:
这是为何:

sudo apt-get install ia32-libs*
[sudo] password for chineseli:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting ia32-libs for regex 'ia32-libs*'
Note, selecting ia32-libs-dev for regex 'ia32-libs*'
Note, selecting ia32-libs-gtk for regex 'ia32-libs*'
Note, selecting ia32-libs-sdl for regex 'ia32-libs*'
Note, selecting ia32-libs-openoffice.org for regex 'ia32-libs*'
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

sudo apt-get install ia32-libs ia32-libs-dev ia32-libs-gtk ia32-libs-sdl ia32-libs-openoffice.org
昵称: syrano  时间: 2008-07-21 14:08:00
ls这个命令也试过了,结果令人心碎:

我用的是cn99和台湾的源

sudo apt-get install ia32-libs ia32-libs-dev ia32-libs-gtk ia32-libs-sdl ia32-libs-openoffice.org
[sudo] password for chineseli:
Reading package lists... Done
Building dependency tree
Reading state information... Done
ia32-libs is already the newest version.
Package ia32-libs-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
ia32-libs lib32z1-dev lib32bz2-dev
E: Package ia32-libs-dev has no installation candidate
昵称: chineseli  时间: 2008-07-21 15:05:00
chineseli 写道:
ls这个命令也试过了,结果令人心碎:

我用的是cn99和台湾的源

sudo apt-get install ia32-libs ia32-libs-dev ia32-libs-gtk ia32-libs-sdl ia32-libs-openoffice.org
[sudo] password for chineseli:
Reading package lists... Done
Building dependency tree
Reading state information... Done
ia32-libs is already the newest version.
Package ia32-libs-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
ia32-libs lib32z1-dev lib32bz2-dev
E: Package ia32-libs-dev has no installation candidate

这条应该可以
sudo apt-get install ia32-libs ia32-libs-gtk ia32-libs-sdl ia32-libs-openoffice.org
昵称: syrano  时间: 2008-07-21 15:45:00
问题依旧……

sudo apt-get install ia32-libs ia32-libs-gtk ia32-libs-sdl ia32-libs-openoffice.org
[sudo] password for chineseli:
Reading package lists... Done
Building dependency tree
Reading state information... Done
ia32-libs is already the newest version.
Package ia32-libs-gtk is a virtual package provided by:
ia32-libs 2.2ubuntu11
You should explicitly select one to install.
E: Package ia32-libs-gtk has no installation candidate
昵称: chineseli  时间: 2008-07-22 13:46:00
chineseli 写道:
问题依旧……

sudo apt-get install ia32-libs ia32-libs-gtk ia32-libs-sdl ia32-libs-openoffice.org
[sudo] password for chineseli:
Reading package lists... Done
Building dependency tree
Reading state information... Done
ia32-libs is already the newest version.
Package ia32-libs-gtk is a virtual package provided by:
ia32-libs 2.2ubuntu11
You should explicitly select one to install.
E: Package ia32-libs-gtk has no installation candidate

ls看不懂英文吗?

改成
sudo apt-get install ia32-libs ia32-libs-sdl ia32-libs-openoffice.org
昵称: syrano  时间: 2008-07-22 14:18:00
搂住这个好像有点错误把。
昵称: cqyd2008  时间: 2008-07-31 14:14:00
这个的确是最好用的方法,我刚刚转好了QQ
昵称: 到处乱走  时间: 2008-08-01 21:40:00
ac@ac-desktop:/mnt/winY/downloads$ sudo getlibs xdict_1.0.3-2_i386.deb
Cannot determine the dependencies required by this program, it may be a script:
If this program needs a 32-bit library use:
getlibs -l i386librarytoinstall.so
If this program needs a 64-bit library use:
getlibs -64l amd64librarytoinstall.so


我安装32位的金山出问题?。。请问怎么解决。。谢谢。
昵称: acoo  时间: 2008-08-03 10:56:00
acoo 写道:
ac@ac-desktop:/mnt/winY/downloads$ sudo getlibs xdict_1.0.3-2_i386.deb
Cannot determine the dependencies required by this program, it may be a script:
If this program needs a 32-bit library use:
getlibs -l i386librarytoinstall.so
If this program needs a 64-bit library use:
getlibs -64l amd64librarytoinstall.so


我安装32位的金山出问题?。。请问怎么解决。。谢谢。

sudo getlibs -l i386librarytoinstall.so
昵称: syrano  时间: 2008-08-03 12:25:00
果然是好东西,学习!
昵称: sxyxbat  时间: 2008-08-08 08:24:00
我发现安装 ia32-libs*的时候,只要安装ia32-libs这一个包就可以了,其它的不要安装。然后按楼主说的下载
http://www.boundlesssupremacy.com/Cappy ... 05-all.deb包,安装后就可以安装32位包了。我的腾讯QQ是这么装上的。

不知道rpm包或者需要自己编译的包怎么安装啊?
昵称: xhsh  时间: 2008-08-17 09:54:00
:o 非常感谢,非常有帮助
昵称: yuwensheng  时间: 2008-08-17 13:12:00
似乎IA-64不兼容32bit,x86-64架构是可以的~~~
昵称: cuihao  时间: 2008-08-17 18:58:00
IA-64和IA-32是完全不一样的,就像当于X86于powerPC之间一样。
据说IA-64可以运行x86程序,但~~~效率极低
昵称: szjuntao  时间: 2008-08-18 14:00:00
我安楼主的方法作了,可是出现了这个
xiaoyu@xiaoyu-desktop:/media/DATA/下载$ sudo dpkg -i --force-architecture gmlive_0.20b3-1_i386.deb
dpkg - 警告,由于您打开了 --force 选项,我忽略了一些问题的存在:
软件包的体系架构(i386)与本机系统的架构(amd64)不符
(正在读取数据库 ... 系统当前总共安装有 156702 个文件和目录。)
正预备替换 gmlive 0.20b3-1 (使用 gmlive_0.20b3-1_i386.deb) ...
正在解压缩将用于更替的包文件 gmlive ...
正在设置 gmlive (0.20b3-1) ...

这个是什么意思阿?
昵称: xiaoyu2790  时间: 2008-08-19 10:42:00
说明你已经完成安装了 :D
接下来就打开它试试用不用的了吧 :D
昵称: szjuntao  时间: 2008-08-19 11:49:00
发表评论
昵称:
内容:
验证: