用户名: 密码: 忘记密码? 注册
收藏此问题 发表新评论

Ubuntu 10.04 安装Nvidia显卡后开机花屏完美解决(图解)

我的本本电脑经过了1个多星期的整治。终于声音正常了。

这些其实是linux系统的bug问题,个人觉得。我在我们论坛看到一位大哥发帖说。

{方法很简单,打开音量控制,找到External Amplifier开关,让其显示出来。如果这个后面的对号是选中的,把对号去掉。 }

我照他的方法去做了。果然。我的本本从以前的没有一点声音。变成了当我插上耳机的时候耳机有声音。本本自带的小喇叭还是没声音。不管怎么说。总比以前好很多了。


后来。我又在网上查找了一些文章。有一位高手说。
{打开音量控制',在弹出的面板上找到'Headphone Jack Sense' 将下面的静音打上对号,还有'Line Jack Sense'下面的静音也打上对号.这时你就能听到'铛'的一声了,声音就出来了. }


我又照他说的方法去做了。 果然。全部都有声音了。插上耳机,耳机有声音。扒掉耳机。本本的小喇叭有声音了。
所以。和我一样的朋友不防试试看。或许对你有帮助/
昵称: 最终完美体  时间: 2007-03-25 18:09:00
我的手提是华硕A8T系列的,Analog Devices AD1986A声卡,装完DUBUNTU后一直没有声音,发现其实有声音但很小,而且杂音很多,基本不能听。
想重装驱动,但又不太会。没想到看了楼主的帖子,按着把那个External Amplifier开关的对号关了,立即就有了声音。

非常感激楼主一个多星期的努力,让我们这些菜鸟享受到了方便!
昵称: skyhawk  时间: 2007-03-30 23:06:00
Thank for help
my notebook have voice!! :P
昵称: swordfish  时间: 2007-04-01 14:05:00
以前一直不知道打开音量控制,拨云见日啊,谢谢楼主! :D
昵称: RegentW  时间: 2007-04-02 14:35:00
时间: 2007-3-30 周五, 23:06 标题: 强啊!

--------------------------------------------------------------------------------

我的手提是华硕A9T系列的,但是按照上面做了仍然没有声音,不知是哪里还有问题,各位能不能把你们的各项设置给个截图啊
实在没办法了
弄了好长时间了 :cry:
昵称: alphahaier  时间: 2007-04-03 18:28:00
是啊,能截图么?设置了还是不管用~
谢谢
昵称: andy_tok  时间: 2007-04-08 12:29:00
好神奇,我的也是无缘无故没有声音了,但是看了你的贴我试着随便检查一下真的就有声音了:)
昵称: hongmy525  时间: 2007-04-09 21:59:00
楼主说的“External Amplifier开关”,和“Headphone Jack Sense”都找不到,麻烦传个图上来吧,谢了。
我装的是ubuntu6.10,现在音箱响,耳机不响,我发现控制音响的是音量控制中的surround标签。
昵称: lijun2049  时间: 2007-04-10 19:52:00
我安楼主的方法试过了,还是没声音!
奇怪的是,7.04版不论怎么调都没声音。6.10安装好后就有声音,也不用调~~
昵称: taraxacum  时间: 2007-04-12 05:22:00
我 也 一样 。610还自己就有 ,可是 移到704,就 没了
昵称: dingyulong  时间: 2007-04-16 18:35:00
楼主说的“External Amplifier开关”,和“Headphone Jack Sense”都找不到,麻烦传个图上来吧,谢了。
昵称: nbdxkfq  时间: 2007-04-21 16:38:00
我的也找不到,而且我的是小喇叭有声音,插上耳机却没声音。。。
昵称: 渔船阵  时间: 2007-04-22 14:30:00
如下面的抓图。 首先点垃叭 选择编辑。
附件:
Screenshot-3.png
Screenshot-3.png [ 307.84 KiB | 被浏览 4742 次 ]

Screenshot-2.png
Screenshot-2.png [ 309.92 KiB | 被浏览 4590 次 ]

Screenshot-1.png
Screenshot-1.png [ 299.82 KiB | 被浏览 4417 次 ]

Screenshot.png
Screenshot.png [ 295.63 KiB | 被浏览 4313 次 ]

昵称: 最终完美体  时间: 2007-04-22 21:06:00
我的选项怎么不一样,那几个都没有阿
昵称: 渔船阵  时间: 2007-04-22 21:24:00
渔船阵 写道:
我的选项怎么不一样,那几个都没有阿


me too
昵称: ole  时间: 2007-04-22 23:04:00
我的也选项也不一样,郁闷
昵称: yy0503  时间: 2007-04-23 21:13:00
我的是intel集成声卡,也没有声音了!为什么阿 ??原来用ubuntu6.6还好好阿!
昵称: duyucong  时间: 2007-04-24 20:53:00
still no voice
my notebook is A8F asus
昵称: firstman  时间: 2007-04-27 15:24:00
我这也没有External Amplifier和Headphone Jack Sense
我的办法是: 音量控制——>开关——>所有的勾都选上, 音量控制——>回放——>取消Surround的静音
昵称: lindazhang  时间: 2007-04-27 20:43:00
我的也没有,同问
昵称: defmys  时间: 2007-04-27 23:29:00
thanks very much. Finally, I have the sound in 7.04
昵称: lifequan  时间: 2007-05-04 08:25:00
我的机箱前面的音频接口不出声,链接是正确的,因为在xp下使用正常!!这种方法都试过了,没用
昵称: woainba15  时间: 2007-05-04 13:24:00
音量控制 的选项是根据 声卡 的不同而不同 的。

这个 是我 的,
ps 我看 我声卡叫什么SB, 还真是够SB 的 = =|||
附件:
文件注释: 看一 下音量控制中 的配图说明 , 是不一样 的。
snapshot4.png
snapshot4.png [ 64.03 KiB | 被浏览 795 次 ]

snapshot3.png
snapshot3.png [ 18.11 KiB | 被浏览 775 次 ]

snapshot2.png
snapshot2.png [ 15.74 KiB | 被浏览 759 次 ]

snapshot1.png
snapshot1.png [ 16.44 KiB | 被浏览 747 次 ]

昵称: zhfm622  时间: 2007-05-07 13:00:00
我的搞定了
我是把pcm调大就可以了
昵称: zihan1209  时间: 2007-05-09 19:08:00
最终完美体 写道:
我的本本电脑经过了1个多星期的整治。终于声音正常了。
{打开音量控制',在弹出的面板上找到'Headphone Jack Sense' 将下面的静音打上对号,还有'Line Jack Sense'下面的静音也打上对号.这时你就能听到'铛'的一声了,声音就出来了. }


哈哈,终于解决了我两年的问题──插上耳机后主机的扬声器还在响。现在插上耳机后扬声器不响,拔掉后响了。真是高兴,非常感谢。
昵称: wyvern2004  时间: 2007-05-12 21:21:00
还是看不懂,自己机子上也没有这些东西,感觉没有声音郁闷
昵称: westlifelz  时间: 2007-05-12 21:48:00
我的是华硕z99f的本,也没有声音,也没有楼主说的那些控制按钮,郁闷!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!有谁能帮帮我啊!
昵称: 紫电清霜  时间: 2007-08-05 07:51:00
刚开机输入用户名之前有提示音,开始进入系统画面的时候也有一段提示音,进入系统之后看电影,放mp3就彻底没声音了。怎么办??
昵称: 紫电清霜  时间: 2007-08-05 07:54:00
我把pcm调大,同时把internal speaker 也调大,就是控制音量的旋钮不管用了,只能通过pcm来调节,但耳机还算正常!
昵称: 小毛孩  时间: 2007-08-06 12:22:00
me 也 too
昵称: aliang032  时间: 2007-10-20 02:18:00
我也没见过这几个选项。。。
昵称: reshine  时间: 2007-10-20 11:24:00
我的更加离谱,只有回放里面一个选项,开关什么的都没有!
昵称: choifyken  时间: 2007-10-20 19:24:00
网上看来的。我的也是A9T没声音,照楼主的做法还是不行。网上看到一篇文章说“其实只要开两个东西就可以发声了,在ubuntu里,开master surround ,另一个是exchange front/surround就可以了”,照做,有声音了。
昵称: zhangcheng1228  时间: 2008-04-04 20:49:00
其实只要声卡能够被驱动,你的系统就应该可以出声。检查声卡被驱动,只要在命令行下用aplay播放一下wav文件就知道了。如果没有声卡,或者没有驱动,会有错误提示给你的。
然后就直接在命令行下用alsamixer来调。图形界面的,很文件。实在出不了图形界面(例如远程ssh登录,你还可以用amixer这个非图形界面的调音器)
昵称: tandkzy  时间: 2008-04-05 11:19:00
不知不觉在无声的情况下已经用了那么久了,想不到这次终于重见天日了。
不顶良心过不去啊!
昵称: questionlin  时间: 2008-07-26 22:33:00
我的虽然和lz不太一样,但是思想基本是相同的
声卡soundmax ad1980 驱动了 但是没声音(8.04)
双击音量按钮 edit-pro。。在里面看得顺眼的都打勾
在下面的选项卡中switches - exchange....打勾
选项卡 options - surround。。。 选indenpandent
选项卡playback - mastersurround 就可以控制音量了

看来真是bug?
昵称: getgame  时间: 2008-07-30 23:40:00
I have no woice,我安楼主的方法试过了,还是没声音! I use Ubuntu 8.04
昵称: wokin  时间: 2008-08-21 23:46:00
:em20
找不到那些选项啊。。。。第一个找到E A那个找到,没用。。。。
后面就都找不到了。。。 :em20 :em20 :em20
昵称: squallhx  时间: 2008-10-26 07:23:00
注定是哑巴了
昵称: cdisk  时间: 2008-10-26 21:22:00
我也遇到过同样的问题,我的是hp的本本,刚装完ubuntu8。10打开播放器,内置音响没有声音插上耳机,耳机里有声音。
如下解决:
打开音量控制,点首选项,将pcm,pcm2打对号,其余都不用.(pcm控制着耳机,pcm2控制内置音响.)
昵称: uu-ljy  时间: 2008-11-03 12:45:00
我的是8.10版,在音量控制里,把首选项中所有的都选上,将speaker调节后,声音就出来了。大家就在这里试吧。
昵称: gowe12  时间: 2008-11-05 19:15:00
谢谢,万分感谢楼主提供的好方法,终于听到声音了!也希望其他受到同样困惑的朋友尽快照此法脱离苦海!
昵称: siang  时间: 2008-12-26 20:39:00
神啊!我的也解决了!
只看了主帖的同学耐心点看看回帖
我也是看不到External Amplifier和Headphone Jack Sense之类的
学上面的同学,把可选的都选上,调了调,就都出来了,插上耳机也可以

感谢楼主!
昵称: horse  时间: 2008-12-26 22:58:00
- -我的HP机子以前好好的有声音的,最近升级后就没声音了,照各位的方法办了也没结果,只有一个治标不治本的方法,终端输入:sudo /sbin/alsa force-reload 之后才能有声音,不过每次开机都要这么来一下,实在是感觉不爽,哪位大虾有方法呢
昵称: levelksk  时间: 2008-12-27 02:47:00
我安的是9。04。。。怎么没有这些呢。。。。。
昵称: wudilove  时间: 2009-04-01 17:48:00
发表评论
昵称:
内容:
验证: