用户名: 密码: 忘记密码? 注册
收藏此问题 发表新评论

怎样快速删除一个包含成千上万个文件/文件夹的文件夹?

代码:
sudo apt-get install gnome-core-devel


引用:
delectate@delectate-laptop:~$ sudo apt-get install gnome-core-devel
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
gnome-core-devel: 依赖: libatspi-dev (>= 1.22.1) 但是它将不会被安装
依赖: libgnomevfs2-dev (>= 1:2.22.0) 但是它将不会被安装
依赖: libgtk2.0-dev (>= 2.13.0) 但是它将不会被安装
依赖: libbonoboui2-dev (>= 2.22.0) 但是它将不会被安装
依赖: libglade2-dev (>= 1:2.6.2) 但是它将不会被安装
依赖: libgnome2-dev (>= 2.20.1.1) 但是它将不会被安装
依赖: libgnomecanvas2-dev (>= 2.20.1.1) 但是它将不会被安装
依赖: libgnomeui-dev (>= 2.20.1.1) 但是它将不会被安装
依赖: libgnome-desktop-dev (>= 2.22.2) 但是它将不会被安装
依赖: libpanel-applet2-dev (>= 2.20.3) 但是它将不会被安装
依赖: python-gnome2-desktop-dev (>= 2.22.0) 但是它将不会被安装
依赖: libgtkhtml3.14-dev (>= 3.18.2) 但是它将不会被安装
依赖: libgtksourceview2.0-dev (>= 2.2.1) 但是它将不会被安装
依赖: libgail-gnome-dev (>= 1.20.0) 但是它将不会被安装
依赖: libgnomekbd-dev (>= 2.22.0) 但是它将不会被安装
依赖: libgnomekbdui-dev (>= 2.22.0) 但是它将不会被安装
依赖: libgnomeprintui2.2-dev (>= 2.18.2) 但是它将不会被安装
依赖: libgweather-dev (>= 2.22.2) 但是它将不会被安装
依赖: librsvg2-dev (>= 2.22.2) 但是它将不会被安装
依赖: libwnck-dev (>= 2.22.1) 但是它将不会被安装
依赖: libnautilus-extension-dev (>= 2.20.0) 但是它将不会被安装
依赖: libtotem-plparser-dev (>= 2.22.3) 但是它将不会被安装
依赖: libvte-dev (>= 0.16.13) 但是它将不会被安装
依赖: python-gnome2-dev (>= 2.22.0) 但是它将不会被安装
依赖: python-gtk2-dev (>= 2.12.1) 但是它将不会被安装
E: 无法安装的软件包
delectate@delectate-laptop:~$
昵称: delectate  时间: 2009-11-14 15:21:00
换过n多源,均是失败

步骤参考:http://forum.ubuntu.org.cn/viewtopic.php?t=40971
昵称: delectate  时间: 2009-11-14 15:21:00
已经安装build - essential

代码:
#include<gtk/gtk.h>


代码:
delectate@delectate-laptop:~$ gcc ./aa.c -o aa `pkg-config --cflags --libs gtk+-2.0`
Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found
./aa.c:1:20: error: gtk/gtk.h: 没有该文件或目录
./aa.c:2: error: expected ‘)’ before ‘*’ token
./aa.c:6: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘delete_event’
./aa.c:11: error: expected ‘)’ before ‘*’ token
./aa.c: In function ‘main’:
./aa.c:17: error: ‘GtkWidget’ undeclared (first use in this function)
./aa.c:17: error: (Each undeclared identifier is reported only once
./aa.c:17: error: for each function it appears in.)
./aa.c:17: error: ‘window’ undeclared (first use in this function)
./aa.c:18: error: ‘button’ undeclared (first use in this function)
./aa.c:20: error: ‘GTK_WINDOW_TOPLEVEL’ undeclared (first use in this function)
./aa.c:21: error: ‘delete_event’ undeclared (first use in this function)
./aa.c:21: error: ‘NULL’ undeclared (first use in this function)
./aa.c:22: error: ‘destroy’ undeclared (first use in this function)
./aa.c:25: error: ‘hello’ undeclared (first use in this function)
./aa.c:26: error: ‘gtk_widget_destroy’ undeclared (first use in this function)
昵称: delectate  时间: 2009-11-14 15:24:00
看准你的系统板本,换个正确的源先
昵称: dbzhang800  时间: 2009-11-14 19:17:00
我也遇到了这个问题,lz解决了吗?
昵称: powerqwe  时间: 2010-04-05 13:46:00
我的也是,烦啊。
昵称: em  时间: 2010-04-21 21:48:00
我也碰到了这个问题,怎么解决呢?
delectate@delectate-laptop:~$ sudo apt-get install gnome-core-devel
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
gnome-core-devel: 依赖: libatspi-dev (>= 1.22.1) 但是它将不会被安装
依赖: libgnomevfs2-dev (>= 1:2.22.0) 但是它将不会被安装
依赖: libgtk2.0-dev (>= 2.13.0) 但是它将不会被安装
依赖: libbonoboui2-dev (>= 2.22.0) 但是它将不会被安装
依赖: libglade2-dev (>= 1:2.6.2) 但是它将不会被安装
依赖: libgnome2-dev (>= 2.20.1.1) 但是它将不会被安装
依赖: libgnomecanvas2-dev (>= 2.20.1.1) 但是它将不会被安装
依赖: libgnomeui-dev (>= 2.20.1.1) 但是它将不会被安装
依赖: libgnome-desktop-dev (>= 2.22.2) 但是它将不会被安装
依赖: libpanel-applet2-dev (>= 2.20.3) 但是它将不会被安装
依赖: python-gnome2-desktop-dev (>= 2.22.0) 但是它将不会被安装
依赖: libgtkhtml3.14-dev (>= 3.18.2) 但是它将不会被安装
依赖: libgtksourceview2.0-dev (>= 2.2.1) 但是它将不会被安装
依赖: libgail-gnome-dev (>= 1.20.0) 但是它将不会被安装
依赖: libgnomekbd-dev (>= 2.22.0) 但是它将不会被安装
依赖: libgnomekbdui-dev (>= 2.22.0) 但是它将不会被安装
依赖: libgnomeprintui2.2-dev (>= 2.18.2) 但是它将不会被安装
依赖: libgweather-dev (>= 2.22.2) 但是它将不会被安装
依赖: librsvg2-dev (>= 2.22.2) 但是它将不会被安装
依赖: libwnck-dev (>= 2.22.1) 但是它将不会被安装
依赖: libnautilus-extension-dev (>= 2.20.0) 但是它将不会被安装
依赖: libtotem-plparser-dev (>= 2.22.3) 但是它将不会被安装
依赖: libvte-dev (>= 0.16.13) 但是它将不会被安装
依赖: python-gnome2-dev (>= 2.22.0) 但是它将不会被安装
依赖: python-gtk2-dev (>= 2.12.1) 但是它将不会被安装
E: 无法安装的软件包
delectate@delectate-laptop:~$
昵称: yangqingkun816  时间: 2010-09-27 23:25:00
根本不是这么搞。
libgtk2.0-dev
昵称: cnkilior  时间: 2010-09-27 23:27:00
代码:
sudo apt-get install gnome-core-devel


引用:
delectate@delectate-laptop:~$ sudo apt-get install gnome-core-devel
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
gnome-core-devel: 依赖: libatspi-dev (>= 1.22.1) 但是它将不会被安装
依赖: libgnomevfs2-dev (>= 1:2.22.0) 但是它将不会被安装
依赖: libgtk2.0-dev (>= 2.13.0) 但是它将不会被安装
依赖: libbonoboui2-dev (>= 2.22.0) 但是它将不会被安装
依赖: libglade2-dev (>= 1:2.6.2) 但是它将不会被安装
依赖: libgnome2-dev (>= 2.20.1.1) 但是它将不会被安装
依赖: libgnomecanvas2-dev (>= 2.20.1.1) 但是它将不会被安装
依赖: libgnomeui-dev (>= 2.20.1.1) 但是它将不会被安装
依赖: libgnome-desktop-dev (>= 2.22.2) 但是它将不会被安装
依赖: libpanel-applet2-dev (>= 2.20.3) 但是它将不会被安装
依赖: python-gnome2-desktop-dev (>= 2.22.0) 但是它将不会被安装
依赖: libgtkhtml3.14-dev (>= 3.18.2) 但是它将不会被安装
依赖: libgtksourceview2.0-dev (>= 2.2.1) 但是它将不会被安装
依赖: libgail-gnome-dev (>= 1.20.0) 但是它将不会被安装
依赖: libgnomekbd-dev (>= 2.22.0) 但是它将不会被安装
依赖: libgnomekbdui-dev (>= 2.22.0) 但是它将不会被安装
依赖: libgnomeprintui2.2-dev (>= 2.18.2) 但是它将不会被安装
依赖: libgweather-dev (>= 2.22.2) 但是它将不会被安装
依赖: librsvg2-dev (>= 2.22.2) 但是它将不会被安装
依赖: libwnck-dev (>= 2.22.1) 但是它将不会被安装
依赖: libnautilus-extension-dev (>= 2.20.0) 但是它将不会被安装
依赖: libtotem-plparser-dev (>= 2.22.3) 但是它将不会被安装
依赖: libvte-dev (>= 0.16.13) 但是它将不会被安装
依赖: python-gnome2-dev (>= 2.22.0) 但是它将不会被安装
依赖: python-gtk2-dev (>= 2.12.1) 但是它将不会被安装
E: 无法安装的软件包
delectate@delectate-laptop:~$
昵称: delectate  时间: 2009-11-14 15:21:00
换过n多源,均是失败

步骤参考:http://forum.ubuntu.org.cn/viewtopic.php?t=40971
昵称: delectate  时间: 2009-11-14 15:21:00
已经安装build - essential

代码:
#include<gtk/gtk.h>


代码:
delectate@delectate-laptop:~$ gcc ./aa.c -o aa `pkg-config --cflags --libs gtk+-2.0`
Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found
./aa.c:1:20: error: gtk/gtk.h: 没有该文件或目录
./aa.c:2: error: expected ‘)’ before ‘*’ token
./aa.c:6: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘delete_event’
./aa.c:11: error: expected ‘)’ before ‘*’ token
./aa.c: In function ‘main’:
./aa.c:17: error: ‘GtkWidget’ undeclared (first use in this function)
./aa.c:17: error: (Each undeclared identifier is reported only once
./aa.c:17: error: for each function it appears in.)
./aa.c:17: error: ‘window’ undeclared (first use in this function)
./aa.c:18: error: ‘button’ undeclared (first use in this function)
./aa.c:20: error: ‘GTK_WINDOW_TOPLEVEL’ undeclared (first use in this function)
./aa.c:21: error: ‘delete_event’ undeclared (first use in this function)
./aa.c:21: error: ‘NULL’ undeclared (first use in this function)
./aa.c:22: error: ‘destroy’ undeclared (first use in this function)
./aa.c:25: error: ‘hello’ undeclared (first use in this function)
./aa.c:26: error: ‘gtk_widget_destroy’ undeclared (first use in this function)
昵称: delectate  时间: 2009-11-14 15:24:00
看准你的系统板本,换个正确的源先
昵称: dbzhang800  时间: 2009-11-14 19:17:00
我也遇到了这个问题,lz解决了吗?
昵称: powerqwe  时间: 2010-04-05 13:46:00
我的也是,烦啊。
昵称: em  时间: 2010-04-21 21:48:00
我也碰到了这个问题,怎么解决呢?
delectate@delectate-laptop:~$ sudo apt-get install gnome-core-devel
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
gnome-core-devel: 依赖: libatspi-dev (>= 1.22.1) 但是它将不会被安装
依赖: libgnomevfs2-dev (>= 1:2.22.0) 但是它将不会被安装
依赖: libgtk2.0-dev (>= 2.13.0) 但是它将不会被安装
依赖: libbonoboui2-dev (>= 2.22.0) 但是它将不会被安装
依赖: libglade2-dev (>= 1:2.6.2) 但是它将不会被安装
依赖: libgnome2-dev (>= 2.20.1.1) 但是它将不会被安装
依赖: libgnomecanvas2-dev (>= 2.20.1.1) 但是它将不会被安装
依赖: libgnomeui-dev (>= 2.20.1.1) 但是它将不会被安装
依赖: libgnome-desktop-dev (>= 2.22.2) 但是它将不会被安装
依赖: libpanel-applet2-dev (>= 2.20.3) 但是它将不会被安装
依赖: python-gnome2-desktop-dev (>= 2.22.0) 但是它将不会被安装
依赖: libgtkhtml3.14-dev (>= 3.18.2) 但是它将不会被安装
依赖: libgtksourceview2.0-dev (>= 2.2.1) 但是它将不会被安装
依赖: libgail-gnome-dev (>= 1.20.0) 但是它将不会被安装
依赖: libgnomekbd-dev (>= 2.22.0) 但是它将不会被安装
依赖: libgnomekbdui-dev (>= 2.22.0) 但是它将不会被安装
依赖: libgnomeprintui2.2-dev (>= 2.18.2) 但是它将不会被安装
依赖: libgweather-dev (>= 2.22.2) 但是它将不会被安装
依赖: librsvg2-dev (>= 2.22.2) 但是它将不会被安装
依赖: libwnck-dev (>= 2.22.1) 但是它将不会被安装
依赖: libnautilus-extension-dev (>= 2.20.0) 但是它将不会被安装
依赖: libtotem-plparser-dev (>= 2.22.3) 但是它将不会被安装
依赖: libvte-dev (>= 0.16.13) 但是它将不会被安装
依赖: python-gnome2-dev (>= 2.22.0) 但是它将不会被安装
依赖: python-gtk2-dev (>= 2.12.1) 但是它将不会被安装
E: 无法安装的软件包
delectate@delectate-laptop:~$
昵称: yangqingkun816  时间: 2010-09-27 23:25:00
根本不是这么搞。
libgtk2.0-dev
昵称: cnkilior  时间: 2010-09-27 23:27:00
发表评论
昵称:
内容:
验证: